My particles do not avoid the coast ... why?

Dear all,
I hope to find advice here regarding my simulation.
I study the dispersion of relatively passive particles (for the moment). The simulation works, but when I want to create my map, some particles are moving on the coast/the land and EVEN IF i change the block "coastline behavior". I also saw advice about timestep here (http://www.ichthyop.org/faq/what-are-different-coastline-behaviours-icht...), but it does not change anything (see the gif below with my files).
How to avoid it? What is my error in the settings?
I enclose my configuration file as well as the description (because they are very heavy files), of my netcdf files inputs.

Thank you for your help / advice!

Ichthyop version:

Hydrodynamic dataset: 
MARS3D

Java version:

Operating system:

Hi Celine

I think it might have something to do with badly set coordinates. In your configuration file, you seem to define longitude/latitude at rho points as ni/nj. However, these are the indices (from 0 to N-1), not the coordinates. You should try to set them as "longitude/latitude", as done in the enclosed file.

Nicolas

Thank you very much, it works