Home >> Forums >> Mercator data

Mercator data

Hello,
I don't succeed to run ichtyop with dataset come from Corpernicus. I recived this message :  Index 0 out of bounds for length 0 | java.lang.IndexOutOfBoundsException: Index 0 out of bounds for length 0. But first, i have the last version of java second, i download netbeans, and then i put netcdf data in input folder with this name : mercator2d-Caraibe.nc and xml files in folder cfg  Caraibe_config_mercactor2d.xml.
How can i resolve this problem ?
 

Ichthyop version: 
Ichthyop 3.3alpha
Hydrodynamic dataset: 
Mercator
Java version: 
Java SE 8
Operating system: 
Windows 10
Attachments: 

Hi

Can you please provide your configuration file? Thanks

Nicolas

Hi,
Thanks for your answer.
Jérôme

Hi Jerome

First, there is a mistake in the configuration file. You need to set the equal to "gridU file pattern" and "gridV file pattern" equal to "mercator2d-Caraibe.nc" (where both velocity fields are stored).

Second, I have encountered issues when initialising the run (I had to modify the code slightly). But still the results are "weird" (a lot of particles die at the domain edges).

Can you try to run the code with the updated configuration (filename + more precise release stain)? If it still does not work, I will provide you with the updated code.

Nicolas

Hi Nicolas,
Thanks a lot but when i do all modification, i recieved a new message : Ichthyop [servere] [Dataset]  Index -1 out of bounds for length 25 | java.lang.ArrayIndexOutOfBounds.
What do i do ?
Jérôme 

Hi Jerome

Can you try the enclosed NetCDF and tell me if it works?

https://filesender.renater.fr/?s=download&token=508b5d2b-c6f7-777b-6f57-...

Thanks

Nicolas

Hi Nicolas,
Thank you for your answers, it works now ! But i have a last question about wind drifter, How can i use NCEP wind (10 m above sea level) nc files to perform a simulation that include windage in ichthyop ?
Thanks
Jérôme

Hi Jerome

Sorry for the very late response (I skipped your request).

To use 2D wind data files to infer wind drift, you need to manually add a new block of options to your configuration file (cf. enclosed file).

When this is done, you should be able to see these new parameters in the Ichthyop GUI. Note however that this module has, to my knowledge, never been fully tested.

Nicolas

Attachments: 

Hi Nicolas,
Thank's for this answer, but i don't success to manually add this new block with enclosed xml file. Can you tell me more carefully, how to do it please ? and when i have to go to do it ?

Hi Jerome.
 

Send me your configuration file, I will add it for you. You can do it by opening the file with Notepad or any text editor.

Nicolas