Home >> Forums >> Initialisation Failed II

Initialisation Failed II

Hi everyone,
 
I was running a simulation but the initialisation kept failing. The log from the failed simulation read:
 
ichthyop[info] ===== Simulation started =====
ichthyop[info] [Simulation] Run 1 / 1
ichthyop[info] [Simulation] Initialising...
ichthyop[info] Opening remote URL http://thredds.jpl.nasa.gov/thredds/dodsC/ocean_circulation/FOR_LAS_ALL_... Please wait...
ichthyop [severe] http://thredds.jpl.nasa.gov/thredds/dodsC/ocean_circulation/FOR_LAS_ALL_... is not a valid URL, return status=400 | java.io.IOException: http://thredds.jpl.nasa.gov/thredds/dodsC/ocean_circulation/FOR_LAS_ALL_... is not a valid URL, return status=400
ichthyop [severe] [Simulaiton] Initialisation failed (performing: SETUP)
 
It says that the URL isn't valid, and going to the URL also seems to yield the same response:
 

Error {
code = 400;
message = "Unrecognized request";
};

 
Is there something wrong with the URL Ichthyop is going to by default?
 
I'm not sure if I'm meant to provide a grid_file either, but here's the configuration file to start with. Any help would be appreciated!
 
Rushan

Ichthyop version: 
Ichthyop 3.3alpha
Hydrodynamic dataset: 
OSCAR
Java version: 
Java SE 8
Operating system: 
Mac OS X

So I've managed a workaround this problem. I'll post the steps I took to get it to work so that if anyone else had the same problem using the OSCAR model, then they can refer to this (or at least for me to refer to when I forget what I did). In summary, I downloaded the netCDF file and made the software get the NetCDF file from my local directory instead of the URL.
TL;DR: (1) I downloaded the actual netCDF file for the OSCAR model for the year I'm looking to do my work in, (2) saved it to my local directory in a folder by itself, (3) set the Source of the dataset as Local NetCDF files and (4) set the input path as where it is saved in. The simulation managed to work.

  1. So something really is wrong with the URL the OSCAR configuration is meant to get the data from (https://thredds.jpl.nasa.gov/thredds/dodsC/ocean_circulation/FOR_LAS_ALL... in <Your configuration> > Main > OSCAR > OpenDAP URL).
  2. What I've done is gone and actually downloaded the data from the NASA website
    1. Go to https://podaac.jpl.nasa.gov/dataset/OSCAR_L4_OC_third-deg
    2. Click on the Data Access tab
    3. The OSCAR netCDF files are living in OPENDAP or FTP under the Direct Access section, so click on either one of them.
    4. You'll be taken to another page where all the OSCAR netCDF files are held, each one corresponding to a particular year. Click on the one you need and the .zip file will download
  3. Once the file is downloaded, save it to a location on your computer of your choice. I chose to plonk it into a file that's in the project I'm working on, but I've kept it in a file by itself and called that file input.
    1. Most importantly, make sure it's the only .nc file in there!
  4. I got back into Ichthyop (I'm using version 3.3) and select the OSCAR model. Save the configuration file to wherever you want to save it to.
  5. Go to <Your configuration> > Main > OSCAR.
  6. In the table with the field Source of the dataset, set it to Local NetCDF files
  7. In the field Input path, click on it, press the ... button on the right, and find the OSCAR netCDF file you just downloaded.
  8. Leave everything else as default.
  9. Set everything else to how you want it and run the simulation; it should work!

So yeah, I suspect the software was going to a dead URL and wouldn't run since it couldn't find anything.
 
As it is, the NetCDF files from the links I provided are on a year-by-year basis. The only thing I'd be concerned about is if you're trying to run a simulation in one year that will go into the next year. I don't actually know if netCDF files can be combined, but then again, I'm not experienced in running these simulations.
 
Is there a way to solve the above problem? Can NetCDF files from different years be combined? Or is there another URL that we can use?
 
Let me know if you know or can think of a solution.
 
– Rushan

Hi Rushan

I am sorry for my late reply. I am surprised because I just ran an Ichthyop simulation by using the default configuration associated with Oscar. It might be an error due to the firewall. Have you run the model from your institution office? If so, have you tried to do this at home?

Regards,

Nicolas

Hi Nicolas,
I can't remember where I saw this from, but if the website works, I should be directed to a website after adding a '.html' after the OpenDAP url. I did that just now and lo-and-behold, the URL works. 
I did run this from my place, but it's not reaching from Ichthyop but I can reach it just fine from an internet browser.
I've gone and figured it out downloading the netCDF file onto my computer so I've managed to figure out a workaround, so it's not big deal. I might just leave it as a firewall issue, though I don't recall doing anything to my firewalls or security since the last time I posted here...

Hi Rushan

I noticed that the URL don't work directly from a Web browser, but it works from Ichthyop. Are you on Linux, Mac  Os or Windows? Do you work with R or Python?

If you are on either Linux or Mac Os, you can try the URL by using the "ncdf4" R library or the "xarray" Python one.

R:

> library("ncdf4")

> file = nc_open("https://thredds.jpl.nasa.gov/thredds/dodsC/ocean_circulation/FOR_LAS_ALL...)

Python:

> import xarray as xr

> data = xr.open_dataset("https://thredds.jpl.nasa.gov/thredds/dodsC/ocean_circulation/FOR_LAS_ALL...)

You will see that the file can be read; the URL is thus valid.

Nicolas