Home >> Forums >> Ichtyop not recognising release stain information

Ichtyop not recognising release stain information

Hi,
We are trying to run backward simulations and having problems during initialisation where it's not recognising our release stain information. We have checked that the coordinates are in the water and not hidden by the mask. 
This is the error message: ichthyop[severe] {Release stain} Unable to release particle. Check out the stain definition. | java.lang.NullPointerException: {Release stain} Unable to release particle. Check out the stain definition.

Do you have any ideas of what we can try to get it working please?

 

Thanks

 

Inge Deschepper and Sarah Schembri

Ichthyop version: 
Ichthyop 3.3alpha
Hydrodynamic dataset: 
NEMO3.6
Java version: 
Java SE 8
Operating system: 
Windows 10

Hi Inge, Hi Sarah.

Could you please send me a sample of your NetCDF input files? Someone had the same problem, which was due to the fact that the particle was considered to be on the domain limit, which prevented the particle to be released.

Nicolas

 

Hi Nicolas,
 
Thank you for the reply. We were thinking it was something along those lines as well but couldn't find the exact issue. 
 
We can't upload a forcing file but we've attached the mesh file. If you need a forcing file, please let us know at which email we can send it to.
 
Thank you
 
Sarah

Hi Sarah

Sorry for my very late response. You can send me a forcing file at nicolas.barrier@ird.fr, I will have a look at it asap.

Nicolas

Hi Nicolas,
Thank you but we realised that there was a problem with our mask files and this issue has been now resolved. We might have more questions later though!
Thank you
Sarah