Home >> Forums >> Global simulation: particles passing to other side of the globe

Global simulation: particles passing to other side of the globe

I am running global simulations with particles uniformly spread throughout the oceans as my initial condition. When particles reach the 'edge' of the globe (-180 (0) or +180 (360) degrees longitude), they don't continue on to the other side but instead stick to the boundary of my grid. The particles reach the edge well within my simulation time, so I would expect them to pass. Is there any way that I can make the particles continue from one edge of my grid to the other?
The attached figure illustrates my issue.
Thank you for any help!

Ichthyop version: 
Ichthyop 3.3alpha
Java version: 
Java SE 8
Operating system: 
Windows 7

Hello

Sorry for the late respose. Which dataset are you trying to read? And which version of the code are you using?

Regards,

Nicolas Barrier

Hello Nicolas,
Thanks for your reply.
I'm running Ichthyop 3.3_r1031. The data I'm using are global mean geostrophic currents; I've saved the data to a netcdf file according to the MARS 2D format.
Ichthyop loads the data and runs fine; the results are as I would expect. The only thing is that particles hit the boundary of the grid. Since I'm running a global simulation, I need the particles that hit the grid boundary on one side to continue on to the opposite side. I was just wondering if there is an option to do this in Ichthyop?
Thanks,
Mirjam

Hello Myriam

Indeed, after checking with Philippe Verley, the periodicity option is not activated with Mars; it is mainly used for regional studies, hence this option was not implemented for this model yet.

We agree that this is something to be done. But in the time being, maybe what you can try to do is to use MERCATOR2D datasets, for which this option should be available. I don't expect that you have many changes to apply to your input files or configuration file.

Please let me know if this solution is ok with you.

Regards,

Nicolas

Hi Nicolas,
Thanks for checking that for me!
It makes sense that's not an option for MARS datasets; earlier I'd converted HYCOM data to the MARS format so I just did that again for my global data. I'll use the MERCATOR dataset instead for global runs!
Thanks again,
Mirjam