Home >> Forums >> Fail in running NEMO

Fail in running NEMO

hello everyone,

I am trying to run ichthyop with a NEMO configuration for the Northwest Atlantic. My input files come differently from what is given as an example (GridT, gridU, gridV, gridW and mask files) to run ichthyop with NEMO:

 L_2016_M2_ave_TSUV.nc: containing data from 2005 to 2016. 

coordinates.nc: containing lon, lat and e1 and e2 variables

Nemo_mask: mask variables and the e3 variables

 

Attached a ncdump of the 3 different files. I mange to run the modele but always fall in a systematic error:

ichthyop[info] ===== Simulation started =====

ichthyop[info] [Simulation] Run 1 / 1

ichthyop[info] [Simulation] Initialising...

ichthyop[warning] Ichthyop will recalculate W variable from U and V

ichthyop[warning] Ichthyop assumes that the NEMO NetCDF files must be opened in enhanced() mode (scale,offset,missing).

ichthyop[info] read lon, lat & mask from /media/baye/BAYE2T/ModelJoelChasse/coordinates.nc

ichthyop[severe] null | java.lang.NullPointerException

ichthyop[severe] [Simulation] Initialisation failed (performing: SETUP)

 

 

What is wrong? Can anyone help me with this?

regards,

Baye

 

 

 

Ichthyop version: 
Ichthyop 3.3alpha
Hydrodynamic dataset: 
NEMO
Java version: 
Java SE 8
Operating system: 
Ubuntu

Hello Baye

I think that the problem is due to the fact that the "depthu" and "depthw" variables are not in the ZGR file (your Nemo_mask.nc file).

The missing depthw is not a problem since if not found, it is estimated from the deptht variable. But the missing depthu may be a problem.

You can try to correct the problem by using NCO.

First, make a backup of your Nemo_mask.nc file:

> cp Nemo_mask.nc save_Nemo_mask.nc

Then append the "depthu" variable from your gridT file into your ZGR file:

> ncks -v depthu 

L_2016_M2_ave_TSUV.nc Nemo_mask.nc

Since NEMO_mask.nc exist, you must choose Append and not Overwrite.

Tell me if it worked. If you still have problems, could you please activate the Console prompt, so that I will have a better idea of where the problem comes from?

Thanks

Nicolas

Hi Nicolas,
You are all right! That were missing variables deptu and depthw in the ZGR file which caused problem. Now all work fine. 
Thanks,
Baye

Dear Nicolas, dear all,
I successfully run ichthop with my NEMO (NEMO 3.6) configuration. Everything seems ok until I decided to plot particles trajectories. It seems particles don't move as their final positions (all) remain in the release area. I noticed the same thing when I look at their trajectories for the mapping and animation compartment from the Ichthyop platform.  
I run my simulation for June in the Northwest Atlantic (Canada), a month which is supposed to be dynamic and then transport particles. Could you try to help me to find what is wrong?
I join the ichthyop configuration file and here is the link for NetCDF files (https://transfernow.net/ddl/BayeNemoConf) used for the run
Regards,
Baye

Hi Baye

The issue is with your NetCDF Files: the valid_min attribute is +1e20, while the valid_max attribute is -1e20.

I managed to solve the issues by using NCO.

Type the following in a terminal:

ncatted -O -a valid_min,vozocrtx,m,d,-1e20 L_Y2005M6_ave_TSUV.nc L_Y2005M6_ave_TSUV.nc
ncatted -O -a valid_max,vozocrtx,m,d,1e20 L_Y2005M6_ave_TSUV.nc L_Y2005M6_ave_TSUV.nc

ncatted -O -a valid_min,vomecrty,m,d,-1e20 L_Y2005M6_ave_TSUV.nc L_Y2005M6_ave_TSUV.nc
ncatted -O -a valid_max,vomecrty,m,d,1e20 L_Y2005M6_ave_TSUV.nc L_Y2005M6_ave_TSUV.nc

ncatted -O -a valid_min,vovecrtz,m,d,-1e20 L_Y2005M6_ave_TSUV.nc L_Y2005M6_ave_TSUV.nc
ncatted -O -a valid_max,vovecrtz,m,d,1e20 L_Y2005M6_ave_TSUV.nc L_Y2005M6_ave_TSUV.nc
 

and it should work.

Nicolas

Hi Nicolas,
Thank you so much for your efficiency. It works fine now :).
Regards,
Baye