Home >> Forums >> bug in time options?

bug in time options?

Bonjour,
Il nous semble qu'il y a un bug dans la gestion du temps :
1) la variable "origin of time" semble n'avoir aucun effet
2) l'année entrée comme "begining of simulation" ne semble pas prise en compte
Exemple :  la date de début (en nombre de seconde) commence bien à 3600 pour year 0001 month 01 day 01 at 1:00
mais c'est encore 3600 pour year 0003 month 01 day 01 at 1:00, ou bien pour n'importe quelle valeur de year.
origin of time ne change rien à rien
 
Salutations,
Timothée & Sidiki
 
 
ichthyop[info] Ichthyop 3.3 (2017/03/23)
java version "1.8.0_20"
 

Ichthyop version: 
Ichthyop 3.3alpha
Hydrodynamic dataset: 
ROMS3D
Java version: 
Java SE 6
Operating system: 
Mac OS X

Hi.

I don't think there is a bug in the time management option, since these parameters have been used extensively without any problems.

Can you please provide the files that you used for the tests?

Nicolas

Hi Nicolas, 
Sorry for the delay ( was on holiday)
Here is the file we used for the test.
Unfortunately we cannot send the roms file (very heavy, but we already checked the srum_time value in the roms file but found no problems…

Best regards,
Timothée
 
 

Attachments: 

Hi Timothee.

Is it not possible to send a small subset of your domain? Because I can't really see what is going on.

However, what you can do is try the dedicated ROMS 3D file instead of the generic configuration file.

Nicolas

Salut Nicolas,
    ci-joins le fichier zone
 
Le fichier ROMS 3D a été aussi testé mais sans succés.
 
Sidiki

Hello,
ok, we are now trying to extract a subset of our roms files. It is long because our roms-file are 60 Go per month (one output per day on a 2km grid that cover all west Africa!!)
I think the pb cannot be tested using the exemple file "roms-benguela.nc" because this does not caontain more than 1 year.
best regards

ichthyop[info] [Simulation] Initialising...
ichthyop[info] {Dataset} Open /Users/timbrochier/Desktop/Bug/baie_han2_avg_Y2001M1.nc
ichthyop[info] Release manager setup [OK]
ichthyop[info] Time manager setup [OK]
ichthyop[info] Instantiated action "Transport/Vertical migration"
ichthyop[info] Instantiated action "Transport/Horizontal dispersion"
ichthyop[info] Instantiated action "Biology/Lethal temperature"
ichthyop[info] Instantiated action "Transport/Advection"
ichthyop[info] Instantiated system action "org.previmer.ichthyop.action.SysActionAgeMonitoring"
ichthyop[info] Instantiated system action "org.previmer.ichthyop.action.SysActionMove"
ichthyop[info] Action manager setup [OK]
ichthyop[info] Output manager setup [OK]
ichthyop[severe] [Dataset] Time value 3.1626E7 (in seconds) not contained among NetCDF files. | java.lang.IndexOutOfBoundsException: [Dataset] Time value 3.1626E7 (in seconds) not contained among NetCDF files.
ichthyop[severe] [Simulation] Initialisation failed (performing: INIT)

Hello Nicolas,
Attached are the config file, the zone file , roms file and the plot of scrum_time in which I see that the time value 3.1626E7 is in the roms file... We probably did something wrong but at the moment I can't figure out what!
ichthyop[info] [Simulation] Initialising...
ichthyop[info] {Dataset} Open /Users/timbrochier/Desktop/Bug/baie_han2_avg_Y2001M1.nc
ichthyop[info] Release manager setup [OK]
ichthyop[info] Time manager setup [OK]
ichthyop[info] Instantiated action "Transport/Vertical migration"
ichthyop[info] Instantiated action "Transport/Horizontal dispersion"
ichthyop[info] Instantiated action "Biology/Lethal temperature"
ichthyop[info] Instantiated action "Transport/Advection"
ichthyop[info] Instantiated system action "org.previmer.ichthyop.action.SysActionAgeMonitoring"
ichthyop[info] Instantiated system action "org.previmer.ichthyop.action.SysActionMove"
ichthyop[info] Action manager setup [OK]
ichthyop[info] Output manager setup [OK]
ichthyop[severe] [Dataset] Time value 3.1626E7 (in seconds) not contained among NetCDF files. | java.lang.IndexOutOfBoundsException: [Dataset] Time value 3.1626E7 (in seconds) not contained among NetCDF files.
ichthyop[severe] [Simulation] Initialisation failed (performing: INIT)
 
Best regards,
Timothée

Hi Timothee

In your configuration file, the time format is not properly set. You provided

year 2001 month 01 day 01 at 1:00

while the proper format is

year 2001 month 01 day 01 at 01:00

Furthermore, I looked at your files, and it seems that the first time step is at 12:00, so you should set:

year 2001 month 01 day 01 at 12:00

Regards,

Nicolas

Bonjour Nicolas,
J'étais pas très actif  car je ne comprends pas très bien l'anglais.
Mais grâce à vous on a pu résoudre notre problème.
Un grand MERCI et très cordialement!!
 
Sidiki